ubuntu 下安装lamp 到php5.4
2017-12-21 作者  Winter    服务器    阅读量277    评论量0

在ubuntu环境下,测试工商银行的接口时遇到的问题,接口要求php环境在5.4以上(也是个坑,测试过程中才发现提示php版本过低)。
首先用ubuntu现有的命令直接装lamp环境的话。受ubuntu ppa源的限制,php只能装到5.3.10版。我的程序需要5.4以上的php。

第一先要把php的安装程序ppa源改成新的,分别是5.4对应 php5-oldstable  和 5.5对应php5
命令如下:
先安装ppa源扩展工具
sudo apt-get install -y ppa-purge 
更新ppa源
sudo add-apt-repository ppa:ondrej/php5-oldstable

更新软件列表。
sudo apt-get update 

手动安装lamp
sudo apt-get install apache2 php5 libapache2-mod-php5 mysql-server libapache2-mod-auth-mysql php5-mysql phpmyadmin

gs.png

上一篇:Centos搭建SVN服务器
下一篇:linux导出与导入mysql数据库

0条评论
热门文章
热评文章
精品课程

¥小额赞助

联系我们

邮箱:chennengit@163.com

手机:13455295173(微信)

QQ:376926761